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Software Support Information 
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subject to applicable fees.  
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from the copyright owner. 
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ReserveIt! Functionality  
 

ReserveIt! is an exciting new way to create, update, and display room agendas 
on digital signs by simply updating an Outlook calendar, by exporting calendar 
data from a different calendar application, or by using a spreadsheet. 
 

             
 

             
 

The functionality of ReserveIt! is divided into tabs corresponding to the 
functions typically performed.  These are: 
 

Displays – selecting the rooms that you want to display agendas for. 
Format – setting the background, fonts, colors, and titles that will appear. 
View – a live view of the agenda that has been created for each room. 
 
There is also a Settings screen where you may set the number of minutes 
between updates, from 1 minute to 4 hours, select the Outlook configuration or 
imported file you want to use, and set the times you want your displays off/on. 
 
With ReserveIt!, everyone who knows how to update a calendar is creating an 
artist-quality room agenda, and distributing it to the digital signs outside of 
each meeting or conference room.  ReserveIt! also creates an “all displays” list 
of meetings for every conference room, which is typically located in a lobby. 
 
Every day, the calendar for that day is shown, without any intervention.  Just 
keep ReserveIt! running on a computer with calendar information!  If you 
want, events that are completed will be removed from the agenda 
automatically.  You may also add images to any event – which will be shown as 
long as that event is on the agenda.  Wedding pictures, guest welcomes, and 
advertising are a few of the uses for this function! 
 
ReserveIt! is compatible with SMIL media players, as well as web browsers.   It 
is also compatible with displays that automatically show JPG images from a USB 
thumb drive.  This allows attractive and functional schedule digital signs to be 
used without a network!  At Best Wave, we want to make your signage program 
productive.  Let us know how we may improve ReserveIt! to meet your needs. 
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Compatible Media Players and screens 
 

ReserveIt! is compatible with two very different types of media players:   
 

1) SMIL Web-server players such as the ViewSonic EP1020r photo frame and 
the ViewSonic NMP-560 OR web browsers such as Internet Explorer. 

2) JPG players built into many types of LCD screens 
 

ReserveIt! also works in situations where both types of players are being used.  
Here is a visual representation of these choices: 
 

 
 

If you are using ANY SMIL web server players, or a web browser, you will 
need to set up a web server as part of the installation process.  This is detailed 
in Appendix A of this user guide.  Please skip to that section now, and set up 
your web server before installing ReserveIt!.  Optionally, you may use your 
corporate web service, where your web site is stored. 
 

After you are done, begin the installation procedure in the next chapter. 
 

Calendar Compatibility 
 

ReserveIt! has been designed with Outlook 2003, 2007, and 2010.  It should 
theoretically work with other versions of Outlook, but it may not work with 
older versions, like Outlook XP.  It is made to work in a private calendar 
environment, a shared calendar environment, and within an Exchange Server 
environment where meeting rooms are scheduled as resources, and each have 
their own calendar and email address. 
 
ReserveIt! is also compatible with many other calendar systems because it can 
import text files containing calendar data.  Optionally, you can load event 
information into a spreadsheet, and save it as a text file.
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Installation  
 
Download the ReserveIt! software from     www.bestwave.com 
 
After downloading, simply double-click the ReserveItInstaller.exe program 
icon.  The installer will create a new folder named BestWave/ReserveIt inside 
the Program Files folder on your hard drive.   Vista users may need to install 
ReserveIt! in a directory other than C:\Program Files because Vista may prevent 
saving and modifying files in that directory. 
 
It will ask you if you would like a shortcut to the ReserveIt! program and to 
this User Guide on your desktop. Here are the contents of the ReserveIt folder: 
 

 
 

 
Shared Content Folder 
 
ReserveIt! stores content such as the room agenda images within another 
folder that it will create; named RCONTENT.   If you are using web-server 
dependent (SMIL) media players, you MUST use the htdocs  folder inside of 
Apache or the wwwroot folder inside of I.I.S. as the content folder. 
 
 Please identify the folder you wish to use for this purpose now. 
 
The first time you run ReserveIt!, you will be asked to locate this folder. 

 
Automatic Operation 
 
ReserveIt! may be set to operate automatically by making a shortcut to the 
program and placing it inside the All Programs>Startup directory.   
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Activating ReserveIt! 
 

This is the software activation screen: 
 

 
 
Fill out the form completely.  ALL FIELDS ARE REQUIRED.   
 

The number of displays is a multiple of 3.  6, 12, 18, 24, etc. depending on the 
number of room displays you have licensed. 
 

Click on the temporary (30-day trial) button the first time you activate the 
software, after you are completely satisfied (and you have paid for your 
licenses), you can re-activate with a permanent activation number.  Your 
activation code will be entered onto the screen within 1 minute and a copy will 
be e-mailed to you.  Activation codes work for 1 hour.  
 

Do not quit the program until you have received and entered the activation 
code, or you will have to repeat this process. 
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Your activation code should appear in the box labeled “Enter the code here:”  
If the field does not have a code, check your e-mail and type it in. 
 

 
 

Click on the Done button, You will then see the splash screen.  Installation is 
complete! 
 

 



ReserveIt! Chapter 4 Settings 

 Page 10  

Settings 
 

To go to the Settings screen, click on the button in the bottom right corner of 
the “Home” screen:  (Note: You may return to the Home screen from anywhere 
in the software by clicking the icon in the top-right corner)   

 
 

This will take you to the Settings screen as shown here: 
 

 
 
Outlook configurations and Imported Text Files 
 

The supported configurations are 1) private Outlook Calendar on this computer, 
2) a shared Outlook calendar, 3) Exchange Server Calendar, or 4) an imported 
text file from a different calendar application or spreadsheet. 
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Changing Settings 
 
The “Test Outlook Connection” button allows you to test each connection type 
to make sure it works with ReserveIt!  If a connection works, you will see a list 
of calendar entries displayed.  Otherwise it will display technical data that you 
can copy and e-mail to support@bestwave.com for assistance. 
 

Minutes between schedule updates – If you are going to display the time on 
your screens, set this to 1, otherwise use a reasonable setting like 5 minutes.  
 
Seconds between agenda pages – This is the number of seconds to show each 
page of a multiple-page agenda.  
 
Note:  You can hold down the + or – button and it will accelerate to go 
quickly from a low number to a high one. 
 
 

Server IP address –This setting allows you to specify the IP of the server you 
are using.  Do not enter the leading “http://”  - enter only the IP address.  
Some valid examples are:    192.168.2.36     OR       bestwave.com/publicsite 
The IP address is NOT required if you are using a USB thumb drive and 
“sneaker-net” instead of a network. 
 
Date Format – You may set ReserveIt! to work with dates in US format 
MM/DD/YYYY or the format used in other countries, DD/MM/YYYY. 
 

Display Images  – ReserveIt! can extract and display multiple JPG and BMP 
images from your Outlook Calendar or text file.  These images are inserted into 
a scheduled event within Outlook, and will be displayed for several seconds, in 
rotation with the Agenda.  If you want the image to be displayed in the All 
Displays agenda, begin its name with “ALL”.  
 

Turn off displays – Select a time for displays to Turn off and back on.  This 
feature only works with SMIL based players and screens.  If you select a time 
for them to turn off, you must also select a time for them to turn back on. 
 

Re-Activate ReserveIt! Software – Click this button if you have purchased 
additional licenses and want to activate them.  The software will not be 
operational while the activation is in process.  
 

Normal Operation Mode 
 
When you first start ReserveIt! you will see the “Home” screen.  You may leave 
the software at this screen.  PLEASE NOTE:  No schedule updates are 
performed while on the Settings Screen, Displays tab, or Format tab.  So, for 
normal operation, just leave it on this screen or go to the View tab.  You may 
minimize ReserveIt! if you wish. 
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Displays 
 

ReserveIt! is divided into 3 sections by the tabs across the top of the screen.  
You may select any tab at any time.  The first tab is for defining Displays.  
Once you have your displays set up, you probably won’t need to go into this tab 
again, unless you add another display to your digital signage program. 
 

But wait!  Did you notice the tip at the top of the screen?  You will save a lot 
of time and effort if you go to the Format tab first, and format your Master.  
Each new display you specify on this screen takes its format from the Master 
format.  So, if you have set it up the way you want, you won’t have to format 
each display individually! 
 

When you click on the Displays tab, you will see one of four possible screens, 
depending upon the Configuration you selected on the Settings screen.  
 

More details about setting up each of the configurations are in the following 
sections, beginning on the next page;  1) Private Calendar Configuration,  
2) Shared Calendar Configuration, 3) Exchange Server Configuration and 4) 
Imported text file. 
 

Near the bottom of every display set-up screen, there is red text indicating 
how many displays you have in use and how many your license allows.  If you 
need more, you can license them, then re-activate from the Settings screen. 
 

Important note: When you add a new display, (and a schedule is generated for 
it) a folder is created inside of the RCONTENT folder.  This content folder is 
either inside the root folder of your web service (for web-server configurations) 
or inside of the same folder that the ReserveIt.exe program is in.  You will 
need to know the path to these folders to set up a networked SMIL player.  
More information regarding this may be found in the following chapter. 
 

Important Note: Spaces in the display’s name are replaced with underscore 
characters.   
 

Important Note:  Do not leave ReserveIt! at the Displays tab after you are 
done.  No room schedules will be produced while you are in this tab. 
 

Important Note:  If Outlook warns you that a program is trying to access e-mail 
information, you can disable the warning in the Outlook Trust Center: 
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1) Private Calendar Configuration 
 

 
 

 
When this screen opens, ReserveIt! will immediately retrieve a list of all of the 
Locations that have been used in any scheduled calendar event over the past 
60 days.  This may take a few seconds.  
 
If no locations come up, go into Outlook and create a new scheduled event and 
type in a location (right below the event name).  Save that event, and click on 
the Displays tab in ReserveIt! again.  Once you see your Outlook Locations, you 
can start adding them to ReserveIt!. 
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To add an Outlook Location to the list of ReserveIt! displays, highlight it in the 
“Outlook Locations” window, and click the Add> Button.   
 
To remove a display, highlight it in the “ReserveIt! Displays” window, and click 
the < Delete Button.   
 
2) Shared Calendar Configuration 
 

 
 
To begin adding displays, you must locate the shared folder you will be using.  
To do this, type its address or name in the “Shared calendar location:” field, 
and click on the “Retrieve Calendar” button. 
 
ReserveIt! will then retrieve a list of all of the Locations that have been used 
in any scheduled calendar event over the past 60 days.  This may take a few 
seconds.  
 
If no locations come up, go into Outlook and create a new scheduled event and 
type in a location (right below the event name).  Save that event, and click on 
the Displays tab in ReserveIt! again.  Once you see your Outlook Locations, you 
can start adding them to ReserveIt!. 
 
To add an Outlook Location to the list of ReserveIt! displays, highlight it in the 
“Outlook Locations” window, and click the Add> Button.   
 
To remove a display, highlight it in the “ReserveIt! Displays” window, and click 
the < Delete Button.   
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1) Exchange Server Calendar Configuration 
 

 
 
 
In Exchange Server configurations, each meeting room is considered a 
Resource, that is scheduled as an attendee to events (meetings) just like 
people and projectors might be.  As one of the “attendees” – the meeting room 
is on the notification list for the meeting and must have its own e-mail address 
set up in the system. 
 

To add displays, type in the name of the room, and its e-mail address, then 
click the “Add>” button.  ReserveIt! will connect to the calendar for that 
room, and then add it to the list of ReserveIt! Displays. 
 

 If for any reason it cannot connect to the calendar (incorrect e-mail address, 
for example) you will receive a notice on screen, and it will not add the room. 
 

To remove a display, highlight it in the “ReserveIt! Displays” window, and click 
the < Delete Button.   
 

Important Note:  If Outlook warns you that a program is trying to access e-mail 
information, you can disable the warning in the Outlook Trust Center: 
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4) Imported Text File Configuration 
 

 
 

 
When this screen opens, ReserveIt! immediately retrieves a list of all of the 
room names in your text file.  This may take a few seconds.  
 
Once you see your locations, you can start adding them to ReserveIt!. 
 

 
 

To add an location to the list of ReserveIt! displays, highlight it in the “Import 
File Locations” window, and click the Add> Button.  To remove a display, 
highlight it in the “ReserveIt! Displays” window, and click the < Delete Button.   
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Format 
 
Each ReserveIt! display can have its own format.  There is also a format called 
the “Master” format, and the “All_Displays” format.  When you set up a new 
display, it gets its initial formatting from the Master, so it is a good idea to set 
the Master format first, and then add displays.  The All_Displays format is for 
displaying events from all rooms on a single (typically large) display. 
 
Click on the Format tab and you will see a screen like this: 

 
 
The pop-up bar at the top shows the name of the room that you are formatting. 
 
Just beneath the name are the aspect ratio buttons.  You may choose either a 
4:3 standard landscape ratio, a 16:9 wide screen aspect ratio or one of two 
portrait aspect ratios.  Your choice must match the display that you are using.  
 
When you initially change aspect ratios you will see a reminder to select a 
different background image.  The background image must be the same aspect 
ratio as the screens you are using.  Here is what that message looks like: 
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ReserveIt! includes sample background images for your use.  You may also 
create your own background image with your company logo and color scheme.  
For 16:9 screens, your background image should be 1366x768 at 72DPI.  For 4:3 
screens, it should be 1024x768 at 72DPI.  Portrait screens are either 768x1366 
or 768x1024.  If most of your signs are the same aspect ratio, set the Master 
format to that ratio.  Here is what the Master looks like in 4:3 Standard Screen 
aspect ratio: 
 

 
 
 
Once you have set the aspect ratio for a screen, you may change what it looks 
like by entering text in the fields, and clicking option buttons. 
 
You can click into the Main Title field, the Sub-Title field, or Footer field to 
change what they say.  Simply highlight the old text and type in the new. 
 
In any of these fields you can also add time and date information by using the 
following phrases (you must include the brackets exactly as shown here): 
 
[long date]   The day of the week, day of the month, the month, and the year 
[short date]  The month/day/year  in the U.S. or  day/month/year elsewhere 
[the time]  The time of day, in AM/PM format or 24hour format   Which format 
depends on the time format you select for the event time… more on that later. 
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You may choose a different background by clicking on the words “Click here to 
select a Background Image…”.  There are numerous sample backgrounds 
included with ReserveIt!, or you can make your own background using an art 
program such as PhotoShop.  
 
ReserveIt! sample backgrounds are divided into three groups, narrow (if you 
are only showing the start time of each event), wide (for start and end time) 
and both, which may be used in either situation. Here, we have selected the 
narrow “Clouds” sample background: 
 

 
 

Notice the text has been changed in the Title, Sub-Title, and footer.  In the 
footer, we have the long date and the time.   
 

If there are more events than will fit, a second screen will be created to 
display the rest.  Events will wrap if their text is too long to fit on a single line. 
 
On the bottom-left of the format screen are some control buttons.  You may 
click on the button that says 12 Hr to change the time format to one that 
displays AM or PM after the time or 24 Hr for the military clock format. 
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A check box in this area allows you to decide if agenda items should be 
removed after their end time has passed.  When this box is checked, they will 
go away after they are done, if not checked, they will stay all day. 
 

 
 
Click on any of the Font buttons to change the text font, size, style and color 
of any of the lines. 
 
For the “All Displays” format, you may also set the divider that will appear 
between the time of a meeting, and the room that it is in.  The default divider 
is the tilde character “~” but it may be changed by simply typing the character 
you prefer into the “Time/Room divider:” field. 
 

 
 
Important note:  You MUST click “Save Changes” to save your new format! 
 
Important Note:  Do not leave ReserveIt! at this tab after you are done 
formatting.  No room schedules will be produced while you are in this tab. 
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View 
 
The View tab allows you to see the schedule display for each room.  You can 
also export the schedule screen to a USB thumb drive.  Select the room name 
from the pop-up tab and you will see what the schedule display looks like: 
 

 
 

If there are more scheduled events than can fit on a single screen, there will 
be additional screens.  They cycle according to the “seconds between agenda 
pages” setting on the Settings screen. 
 

 
 
The first selection in the pop-up is “All_Displays.”  This contains all events 
from all of the rooms, in time sequence.  All-day events appear first.  This is 
designed for use with a large screen at an entrance or hallway. 
 
Click the “Export to USB drive” button to select a drive, and export the JPG 
images, the index.html file and the index.smil file to a USB thumb drive which 
can then be plugged into a SMIL compatible player.  Other media players and 
LCD screens with JPG playback capability or internet browsers also work.  The 
USB drive should not have any other data on it when you do this.
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Outlook 
 
Adding new schedule events 
 
When adding a new event to Outlook, you must either select the location of the 
meeting using the Location pop-up menu, as shown in this example, or add the 
room as a resource in the Scheduling tab for the event.  The Location field is 
used for Private Calendar configurations and Shared Calendar configurations, 
while the resource is used if you are using an Exchange Server and each of your 
meeting rooms has its own calendar and email address.  The Location method is 
shown here: 
 

 
 
If you are entering a Location name, do not type it in, use the pop-up!  Except 
for the very first time you schedule something in a room, the Location should 
always be selected from the pop-up menu.  That way you have consistency in 
spelling and capitalization. 
 
Attaching an Image to an Event 
 
ReserveIt! looks at each scheduled event to see if it has a JPG or BMP file 
associated with it.  These images will be shown along with the normal agenda.  
First the agenda will appear, then the image associated with the earliest 
event, then the agenda again, then the next event’s image, and so forth.  If 
the image file name begins with the letters “all” then the image will ONLY 
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appear on the All-Displays screen.  This allows two images with different aspect 
ratios to be associated with the same event, one for the room screen and one 
for the lobby screen (which might be portrait orientation). 
 
To add a JPG or BMP file to an event simply use the File… command from the 
Insert menu as shown here: 
 

 
 

In this example, the PhxSunsWelcome JPG image has been inserted into the 
appointment item “Meeting with Phoenix Suns Executives.” 
 

 
 
This image was actually created in PowerPoint, and the Save as… selection 
from the File menu was used to save it as a JPG image.  To make it fit the 
screen properly, the PowerPoint Page Setup was set to 13.66 inches wide and 
7.68 inches high – thereby insuring that the aspect ratio would be the same as 
the ReserveIt! screen. 
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All Day Events 
 
All day events are listed on ReserveIt! schedules in the order that they were 
added to the calendar, not in alphabetical order.   
 
Outlook will show them to you in alphabetical order, which can be confusing.  
Of course they will not have a time associated with them, and they will appear 
before any events with times.  For this reason, using all day events is not a 
good way to create schedules that are actually lists, like this menu: 
 

 
 
A better way to create this display is to use the Format tab in ReserveIt! to 
turn off the start time, and end time.  Then enter each of the menu entries as 
an event, with the ones you want at the top scheduled earlier in the day than 
the others. 
 
For most applications, your all day events will appear first in the agenda list, 
followed by events that have times associated with them as in this example: 
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Imported Text Files 
 
File Format 
 
ReserveIt! accepts many different types of formatted text files so that it may 
be used with almost any calendar application.  Here is an example from 
MicroSoft Excel: 
 

 
 
This example has a heading line.  When ReserveIt! sees a heading line, it will 
look for certain key words that tell it what columns have what data in them.  
The key words are as follows: 
Date - the event date 
Room  - the name of the room the event is being held in 
Start - the time of day the event begins 
End - the time of day the event ends 
Subject the meeting subject matter 
Image - the path to a JPG or BMP file that should be shown with this event 
 
There can be additional words in the heading, as ReserveIt! is looking for the 
key word to be contained within the heading.  So, “Meeting Start Time” or 
“Start” or “Start Time” would all work. 
 
If there are no headings for ReserveIt! to use, or the headings do not contain 
all of the key words, the columns are assumed to be in the same order as the 
example above. 
 
Field Delimiters 
 
ReserveIt! accepts several delimiters between the columns of data.  Delimiters 
may be commas, tabs,  or the pipe character (“|”).  Excel saves spreadsheets 
in text files delimited by commas when you use “Save As…” from the file menu 
and select CSV (Comma delimited) from the dialog box.  It can also save files as 
tab delimited using the TAB (Tab delimited) selection. 



ReserveIt! Chapter 9 Imported Text Files 

 Page 26  

 
Your calendar application will most likely have an export function that allows 
you to select the data fields you want to export, as well as the delimiter you 
want between fields. 
 
Attaching an Image to an Event 
 
ReserveIt! looks at each scheduled event to see if it has a JPG file associated 
with it.  These images will be shown along with the normal agenda.  First the 
agenda will appear, then the image associated with the earliest event, then 
the agenda again, then the next event’s image, and so forth. 
 
To add an image to an event, place its name in the Image column.  If the file is 
in the same folder as the text file, it does not need a complete path – it can 
just have the file name (as shown in the example on the previous page).  If the 
file is elsewhere, it must have a complete path beginning with the drive letter 
for example - C://Pictures/GuestWelcome.jpg 

 
In the example on the previous page, the GuestWelcome.jpg image has been 
inserted into the appointment item “Informal discussion group meeting.” 
 

 
 
This image was actually created in PowerPoint, using the Save as… selection 
from the File menu to save it as a JPG image.  To make it fit the screen 
properly, the PowerPoint Page Setup was set to 13.66 inches wide and 7.68 
inches high – thereby insuring that the aspect ratio would be the same as the 
ReserveIt! screen. (16:9 in this case) 
 
All Day Events 
 
All day events are listed on ReserveIt! schedules in the order that they were 
added to the calendar, not in alphabetical order.   To signify an all day event, 
use the start time 12:00 AM (00:00) and the same end time. 
 
They will not have a time associated with them on the agenda, and they will 
appear before any events with times. 
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Setting up SMIL Media Players for Network Operation 
 

Step 1 
 

Plug a USB keyboard into the media player, then when the menu comes up, 
select the Content Directory option. 
 

Step 2 
 

Figure out the correct URL for this media player.   Example URL: 
 

http://192.168.1.100/RCONTENT/Room_Name/index.smil 
 

Note: Case is significant! 
replace 192.168.1.100 in with the IP address of your web service 
replace Room_Name with the name of the display (meetng room) 
(remember, always use underscores ‘_’ NOT spaces ‘ ‘) 
 

So, if you have a room named “Corporate Boardroom” and the IP address of 
your web service is 192.109.100.2 you would use this URL: 
 

http://192.109.100.2/ RCONTENT/Corporate_Boardroom/index.smil 
 

Step 3 
 

Type the URL into the content directory, and save the changes.  You may now 
unplug the USB keyboard, and allow the media player to function normally.  
Your schedule displays will begin appearing soon after you start up ReserveIt! 
 

Setting up a Web Browser for use with ReserveIt! 
 

Step 1 
 

Figure out the correct URL for this display.  (See Step 2 above) 
 

Step 2 
 

Open your web browser.  Go to the URL for the room you want to display and 
set that URL as the Home page.  The way to do this varies for each web 
browser.  See the help menu for your web browser if you do not know how.   
 

Step 3 
 

Get rid of all controls and menu bars within your web browser.  Again, this 
varies for each web browser.  Some have a “kiosk mode” menu choice that will 
accomplish this in a single step. 
 

Step 4 
 

Make your web browser start up automatically by adding a shortcut or alias to 
your startup folder for the computer.
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Troubleshooting Network Media Players 
 
The most common issues with ReserveIt! networks occur upon installation, and 
have to do with the server software, permissions on the HTTP server, selecting 
the correct root folder, and hardware issues like video connections from the 
media player to the screen. 
 
Server software A suitable HTTP server must be in use.  It may be Apache, 

I.I.S.,  Linux, or Solaris.  Other HTTP server programs may 
also work.  I.I.S. servers require that you allow the “smil” 
mime type.  You can learn how to do this at:  
http://support.microsoft.com/kb/326965 

 
Permissions Media players cannot login to establish connection to the 

server.  So authentication cannot be required. 
 
Firewalls Firewalls cannot block port 80 from the media player to the 

server and must, in some cases, explicitly allow HTTP 
services for server programs such as Apache.  See Appendix 
A for information on setting your Firewall correctly. 

 
Rights The computer running ReserveIt! must have read, write, 

and delete capability to the RCONTENT folder within the 
root server directory.  This folder is created by ReserveIt! 
thefirst time it is run. 

 
IP Addresses The IP address of the web server must be correct. Type the 

IP into the address line of a web browser to make sure. 
 
Upon installation, you are asked to locate the primary or root directory of your 
HTTP server.  The path to that directory is saved in a text file named 
“ServerFolder.txt” which may be found inside the “Preferences” folder in the 
same directory as ReserveIt! 
 
Here is the content of some typical ServerFolder.txt files: 
 
  C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\ 
  C:\inetpub\wwwroot\ 
  Z:\                            (this is a mapped drive pointing to a server) 
 
If the path you see does not point to the correct place, you may change it, and 
run ReserveIt! again.  Before you run it, move the original RCONTENT folder 
to the new location.  Otherwise it will ask you to activate once again. 
 
From a user workstation, with a mapped drive to the same folder above, the 
ServerFolder.txt file would simply contain:     Z:\    (substitute the correct 
mapped drive letter for the letter “Z” used in this example). 
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IP address 
 
When you “point” your media player to the content location, the first part of 
the URL is the IP address of the web server.  If you installed Apache on your 
computer as part of this installation, you have to know the IP address of your 
computer. 
 
You can find out what that address is by starting up the Command Prompt from 
the Start Menu > Accessories option and typing the command “ipconfig” then 
hitting Enter: 
 

 
 
Write down the IP address.  It will be the first part of the “Get content from:” 
URL that you set the media player to. 
 
Room Names 
 
When you start adding events into Outlook and giving each event a location, 
make sure to use the pop-up menu for the location name so that all the room 
names are consistent.  There is a big difference between “Conference Room 1” 
and “Conference room 1” for this purpose. 
 
Also, when entering the room name as part of the URL string, remember to 
replace all spaces with underscores “_” as in this example:   
Conference_Room_1   And, never use punctuation in a room name.  Letters 
such as “%”, “:”, and “/” have significance and will make your system not 
work.
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Setting up a web server 
 
Some network media players pull content from a web (HTTP) server.  These 
include the EP1020r Photo Frame and NMP-560 from ViewSonic.  If you are 
using one of these, or if you are using a web browser to display room 
information, you must have a web server running on your computer, or be able 
to access the web server on your corporate network.  If you are using ONLY USB 
thumb drives to carry data to your players, you can skip this section.   
 
There are two options for the web server, a corporate server, or a web 
service running on the same workstation computer as ReserveIt!. 
 
Option 1 – Use a corporate network HTTP server 
 

Map the disk drive on the web server you will be using. It must be 
automatically re-mounted when the workstation computer starts up.   
 
You must know the IP address of the server.  You can get that from your 
system administrator. 
 
When ReserveIt! runs for the first time, it will create a folder named 
RCONTENT inside the server’s root directory.  Your system administrator 
needs to give you permission to create, modify, and delete files within 
the “RCONTENT”  directory on the web server.  The administrator may 
limit your ability to create and delete files to just the RCONTENT directory.  
You do not need permissions for other directories within the server’s root 
directory. 

 
Option 2 – Run HTTP server software on your computer 
 

Any HTTP server software, such as IIS from Microsoft, or Apache Server 
Software is fine.  If you decide to use Apache Server software on your 
computer, and are running Windows XP, you may run the standard installer 
which is inside the  ReserveIt/Apache Server Installer  folder. 

 

If you need a different installer, download it from: 
http://httpd.apache.org/    Go to the Binaries folder and find your 
operating system before downloading.  As of the printing of this User Guide, 
there is no charge for Apache Server.   

 

You must know the IP address of your computer (or the server).  To get 
the IP address of a machine, Select Programs>Accessories>Command Prompt 
from the Start menu 
 Type:  ipconfig    and touch the Enter key… 
Your computer’s IP address will be displayed in the result. 
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Important note for Vista and Windows 7 users You may need to turn off User Access 
Control in the Users and Groups control panel to make sure that read and write are 
available.  You must also create an exception for Port 80 in the Windows Firewall. 
 
Vista users may need to install ReserveIt! in a directory other than C:\Program Files 
because Vista may prevent saving and modifying files in that directory. 
 
Every HTTP server has a primary (root) folder.  That is the folder where 
ReserveIt!  content will reside.  For Apache Server it is the “htdocs” folder.  
For IIS it is the “inetpub/wwwroot” folder.  You will need to know where the 
root folder is to complete this installation.   You must have read/write 
permissions to this folder to complete the installation.  The first time you run 
ReserveIt!  you will be prompted to locate the server’s primary folder: 
 

 
 

In the above example, the htdocs folder (for Apache Server) is highlighted.  
After locating the primary folder for your server, click the OK button.  Now, go 
to the folder you selected above, and view its properties.  The Read Only box 
should not be checked.  If it is, uncheck it, and apply to all sub-folders as well. 
 
After Activation, ReserveIt! will create a sub-directory within the primary 
folder.  This folder will be named “RCONTENT”  You must continue to have 
read/write permissions to this folder!!! 
 
There are some very important control panel settings that must be set for your 
web server to work properly.  You must allow HTTP services within the 
Windows Firewall.  This is necessary even if Windows Firewall is off.  Go to the 
Advanced tab, and select your network, then click on Settings.  Make sure the 
HTTP Web Service checkbox is checked. 
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IIS Mime Types 
 
If you are using Microsoft IIS for your web service, it must have .smil as a mime 
type.  To add this, perform the following steps: 
 

1) Start IIS Manager, and click on the HTTP Headers tab. 
2) Click the Mime Type button on the bottom right of that window. 
3) Click Add 
4) Type “smil” as the file extension you want to add 
5) Type “smil media player support” into the text box 
6) Click OK 


